1

Closed

I'm getting Error in both On-Premise and On-Line

description

After filling the login information while the application show in the status bar "Create organization service proxy" I get this error :
Error: Object reference not set to an instance of an object.
See attach image.

file attachments

Closed Jul 21, 2011 at 10:14 AM by tanguy92

comments

tanguy92 wrote Jul 21, 2011 at 5:32 AM

May i know what values you put in the connection form?

Are you aware of a specific proxy settings on your network?

shaibarlev wrote Jul 21, 2011 at 6:03 AM

No special proxy settings. its happened in 2 different sites ,one in client site on-premise internal network AD default windows authentications. the second is my CRM online that I have IE or Outlook client connected all the time with no extra proxy settings. If you want we can set private remote session. BTW- your other editor work fine (SiteMap for example)

tanguy92 wrote Jul 21, 2011 at 6:53 AM

I will check if the connection part is identical for both tools and post a new version soon

shaibarlev wrote Jul 21, 2011 at 7:39 AM

I found where its break at :
Mainform.cs line 107 : if (e.Parameter.ToString() == "OpenSolution")
e.Parameter is null.

tanguy92 wrote Jul 21, 2011 at 7:57 AM

Ok, thank you, I'll fix this bug and post a new version in few hours

shaibarlev wrote Jul 21, 2011 at 8:34 AM

For testing I add this before the line with the problem:
e.Parameter = "OpenSolution";
The I selected solution (Actually I added a new one) And then the connection worked and I got under the left side Element , General , Application Ribbon, but when I try to select Application Ribbon I got the error below 3 times and the I got the the treeview with the Ribbon elements in the middle panel.

An error occurred: System.ArgumentException: Must specify valid information for parsing in the string.
at System.Enum.TryParseEnum(Type enumType, String value, Boolean ignoreCase, EnumResult& parseResult)
at System.Enum.Parse(Type enumType, String value)
at RibbonEditor.CommandUIDefinitionClasses.MenuSection..ctor(XmlNode node) in C:\Projects\ribboneditor\RibbonEditor\RibbonEditor\CommandUIDefinitionClasses\MenuSection.cs:line 33

shaibarlev wrote Jul 21, 2011 at 9:11 AM

Another test I did on MS Partner VM , I try to connect to organization Contoso and got this error :
Error: The specified path, file name, or both are too long. The fully qualified file name must be less than 260 characters, and the directory name must be less than 248 characters.

tanguy92 wrote Jul 21, 2011 at 10:02 AM

easy, easy :)

I widh you could create a new issue for each problem but for these ones, forget it...

I upload a new version in few minutes

wrote Jul 21, 2011 at 10:11 AM

wrote Jul 21, 2011 at 10:11 AM

wrote Jul 21, 2011 at 10:14 AM

Resolved with changeset 7720.

tanguy92 wrote Jul 21, 2011 at 10:16 AM

For the length error message, it is because the tool is stored in too much subfolders, and the unzip operation can't happen due to the length of the path

wrote Feb 14, 2013 at 7:49 PM

wrote May 16, 2013 at 9:25 AM